Dienstag, 5. April 2011

Formeln für Excel (Datenreduktion durch Mittelwertbildung)

Hat man sehr viele Messwerte und möchte die Datenmenge reduzieren, so bietet es sich an den Mittelwert von zum Beispiel je 10 Werten zu bilden. Um nicht für jeden Datenblock jede Formel zu tippen kann man sich die Offset-Funktion zu Hilfe nehmen.
=MITTELWERT(BEREICH.VERSCHIEBEN(A$2;AUFRUNDEN(ZEILE()*10-10;0);;10;))
in einem englischen MS Excel lautet die Formel
=AVERAGE(OFFSET(A$2,ROUNDUP(ROW()*10-10,0),,10,))
Dabei ist A1 der erste Wert der Spalte, die Zahl gibt die Größe des zu mittelnden Bereichs an.

Bei einer anderen Datenreihe liegen Messwerte (Spalte B) mit Zeitstempel (Spalte A) vor. Sie haben einen Abstand von einigen Sekunden und für eine Datenreduktion soll der Mittelwert in stündlichen Zeitintervallen erfolgen. Die Anzahl der Messwerte pro Stunde variiert leicht. In eine neue Spalte (C) werden die neue Zeiten mit gewümschtem Abstand gefüllt (im Beispiel Stündlich: C1 = 05.04.2011 10:00, C2 = 05.04.2011 11:00) und Spalte D füllt man mit folgender Formel
=(SUMIF($A$1:$A$5000,"≶"&C2,$B$1:$B$5000)-SUMIF($A$1:$A$5000,"≶"&C1,$B$1:$B$5000))/60
Allerdings wird diese Formel bei extrem langen Datenreihen langsam.

Kommentare:

  1. einen etwas ausführlicheren Artikel kann man hier finden http://www.excel-helfer.de/funktionen-von-excel-mittelwert-max-und-min.html

    AntwortenLöschen
  2. Hallo Tim, schön gemachter Artikel, vom Inhalt leider nicht passend, da er nur die einfachste Anwendung der Formeln MIN(), MAX() und MITTELWERT() zeigt. Mein Problem der eleganten Reduktion von z.B. langen Zahlenkolonen wird nicht besprochen. Gruß.

    AntwortenLöschen